import Foundation
let pattern = #"\b(?<whole_word>[a-z])\k{whole_word}++\b(*SKIP)(*FAIL)|(?<not_whole_word>[a-z])\k{not_whole_word}++"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
test ajjjo new
here bbb cca
here abbbbbc x
test jjka
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$not_whole_word"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)