#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\b(?<whole_word>[a-z])\k{whole_word}++\b(*SKIP)(*FAIL)|(?<not_whole_word>[a-z])\k{not_whole_word}++"
Local $sString = "test ajjjo new" & @CRLF & _
"here bbb cca" & @CRLF & _
"here abbbbbc x" & @CRLF & _
"test jjka"
Local $sSubst = "$not_whole_word"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)