# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\B[a-zA-Z]|[^0-9a-zA-Z\n]//gm;t' <<< "Apple Banana Cake
1 Banana 2 Orange"