#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\B[a-zA-Z]|[^0-9a-zA-Z\n]"
Local $sString = "Apple Banana Cake" & @CRLF & _
"1 Banana 2 Orange"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)