// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\B[a-zA-Z]|[^0-9a-zA-Z\n]").unwrap();
let string = "Apple Banana Cake
1 Banana 2 Orange";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}