use strict;
my $str = 'Apple Banana Cake
1 Banana 2 Orange';
my $regex = qr/\B[a-zA-Z]|[^0-9a-zA-Z\n]/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";