re = /\B[a-zA-Z]|[^0-9a-zA-Z\n]/m
str = 'Apple Banana Cake
1 Banana 2 Orange'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result