$re = '/\B[a-zA-Z]|[^0-9a-zA-Z\n]/m';
$str = 'Apple Banana Cake
1 Banana 2 Orange';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;