import Foundation
let pattern = #"\B[a-zA-Z]|[^0-9a-zA-Z\n]"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Apple Banana Cake
1 Banana 2 Orange
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)