using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\B[a-zA-Z]|[^0-9a-zA-Z\n]";
string substitution = @"";
string input = @"Apple Banana Cake
1 Banana 2 Orange";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}