const regex = /\B[a-zA-Z]|[^0-9a-zA-Z\n]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\B[a-zA-Z]|[^0-9a-zA-Z\\n]', 'gm')
const str = `Apple Banana Cake
1 Banana 2 Orange`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);