package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\B[a-zA-Z]|[^0-9a-zA-Z\n]`)
var str = `Apple Banana Cake
1 Banana 2 Orange`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}