# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([^\n][^\S\r\n])[^\S\r\n]+/$1/gm;t' <<< "<tr>
<td><strong>Vamos a sentarnos.</strong></td>
<td><strong>Let's sit down.</strong></td>
</tr>
<tr>
<td>veamos (ver)</td>
<td>let's see (to see)</td>
</tr>"