import re
regex = re.compile(r"([^\n][^\S\r\n])[^\S\r\n]+", flags=re.MULTILINE)
test_str = ("<tr>\n"
" <td><strong>Vamos a sentarnos.</strong></td>\n"
" <td><strong>Let's sit down.</strong></td>\n"
"</tr>\n"
" <tr>\n"
" <td>veamos (ver)</td>\n"
" <td>let's see (to see)</td>\n"
"</tr>")
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)