use strict;
my $str = '<tr>
<td><strong>Vamos a sentarnos.</strong></td>
<td><strong>Let\'s sit down.</strong></td>
</tr>
<tr>
<td>veamos (ver)</td>
<td>let\'s see (to see)</td>
</tr>';
my $regex = qr/([^\n][^\S\r\n])[^\S\r\n]+/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";