# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[^\t\n:\[\]]+(?=[^\]]*(\[|$))//g;t' <<< "[[inside]]
outside
this: is a tab here.
\",
\"Fra dato (dd.mm.åååå)\n01.01.2020\",
\"Til dato (dd.mm.åååå)\n31.12.2022\",
\"Delmål med aktiviteter\",
[[D
]]
\"Aktiviteter knyttet til delmål\",
[["