use strict;
my $str = '[[inside]]
outside
this: is a tab here.
",
"Fra dato (dd.mm.åååå)\\n01.01.2020",
"Til dato (dd.mm.åååå)\\n31.12.2022",
"Delmål med aktiviteter",
[[D
]]
"Aktiviteter knyttet til delmål",
[[';
my $regex = qr/[^\t\n:\[\]]+(?=[^\]]*(\[|$))/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";