import Foundation
let pattern = #"[^\t\n:\[\]]+(?=[^\]]*(\[|$))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
[[inside]]
outside
this: is a tab here.
",
"Fra dato (dd.mm.åååå)\n01.01.2020",
"Til dato (dd.mm.åååå)\n31.12.2022",
"Delmål med aktiviteter",
[[D
]]
"Aktiviteter knyttet til delmål",
[[
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)