re = /[^\t\n:\[\]]+(?=[^\]]*(\[|$))/
str = '[[inside]]
outside
this: is a tab here.
",
"Fra dato (dd.mm.åååå)\\n01.01.2020",
"Til dato (dd.mm.åååå)\\n31.12.2022",
"Delmål med aktiviteter",
[[D
]]
"Aktiviteter knyttet til delmål",
[['
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result