import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[^\\t\\n:\\[\\]]+(?=[^\\]]*(\\[|$))";
final String string = "[[inside]]\n"
+ "outside\n"
+ "this: is a tab here.\n"
+ "\",\n"
+ "\"Fra dato (dd.mm.åååå)\\n01.01.2020\",\n"
+ "\"Til dato (dd.mm.åååå)\\n31.12.2022\",\n"
+ "\"Delmål med aktiviteter\",\n"
+ "[[D\n"
+ "]]\n"
+ "\"Aktiviteter knyttet til delmål\",\n"
+ "[[";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}