#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "[^\t\n:\[\]]+(?=[^\]]*(\[|$))"
Local $sString = "[[inside]]" & @CRLF & _
"outside" & @CRLF & _
"this: is a tab here." & @CRLF & _
""," & @CRLF & _
""Fra dato (dd.mm.åååå)\n01.01.2020"," & @CRLF & _
""Til dato (dd.mm.åååå)\n31.12.2022"," & @CRLF & _
""Delmål med aktiviteter"," & @CRLF & _
"[[D" & @CRLF & _
"]]" & @CRLF & _
""Aktiviteter knyttet til delmål"," & @CRLF & _
"[["
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)