# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[^\t\n:\[\]]+(?=[^\]]*(\[|$))"
test_str = ("[[inside]]\n"
"outside\n"
"this: is a tab here.\n"
"\",\n"
"\"Fra dato (dd.mm.åååå)\\n01.01.2020\",\n"
"\"Til dato (dd.mm.åååå)\\n31.12.2022\",\n"
"\"Delmål med aktiviteter\",\n"
"[[D\n"
"]]\n"
"\"Aktiviteter knyttet til delmål\",\n"
"[[")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.