const regex = /[^\t\n:\[\]]+(?=[^\]]*(\[|$))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^\\t\\n:\\[\\]]+(?=[^\\]]*(\\[|$))', 'g')
const str = `[[inside]]
outside
this: is a tab here.
",
"Fra dato (dd.mm.åååå)\\n01.01.2020",
"Til dato (dd.mm.åååå)\\n31.12.2022",
"Delmål med aktiviteter",
[[D
]]
"Aktiviteter knyttet til delmål",
[[`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);