$re = '/[^\t\n:\[\]]+(?=[^\]]*(\[|$))/';
$str = '[[inside]]
outside
this: is a tab here.
",
"Fra dato (dd.mm.åååå)\\n01.01.2020",
"Til dato (dd.mm.åååå)\\n31.12.2022",
"Delmål med aktiviteter",
[[D
]]
"Aktiviteter knyttet til delmål",
[[';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;