using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^\t\n:\[\]]+(?=[^\]]*(\[|$))";
string substitution = @"";
string input = @"[[inside]]
outside
this: is a tab here.
"",
""Fra dato (dd.mm.åååå)\n01.01.2020"",
""Til dato (dd.mm.åååå)\n31.12.2022"",
""Delmål med aktiviteter"",
[[D
]]
""Aktiviteter knyttet til delmål"",
[[";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}