# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[\u2070-\u209f\u00b0-\u00be]+//g;t' <<< "2⁰¹²³⁴sometext⁵⁶⁷⁸⁹"