const regex = /[\u2070-\u209f\u00b0-\u00be]+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[\\u2070-\\u209f\\u00b0-\\u00be]+', 'g')
const str = `2⁰¹²³⁴sometext⁵⁶⁷⁸⁹`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);