import Foundation
let pattern = #"[\u2070-\u209f\u00b0-\u00be]+"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"2⁰¹²³⁴sometext⁵⁶⁷⁸⁹"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)