re = /[\u2070-\u209f\u00b0-\u00be]+/
str = '2⁰¹²³⁴sometext⁵⁶⁷⁸⁹'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result