$re = '/[\u2070-\u209f\u00b0-\u00be]+/';
$str = '2⁰¹²³⁴sometext⁵⁶⁷⁸⁹';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;