using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[\u2070-\u209f\u00b0-\u00be]+";
string substitution = @"";
string input = @"2⁰¹²³⁴sometext⁵⁶⁷⁸⁹";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}