# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(<.+?)\s+style\s*=\s*(["']).*?\2(.*?>)/\1\3/g;t' <<< "<p style=\"margin: 15px 0px; padding: 0px; border: 0px; outline: 0px;\">Hello</p>"