use strict;
my $str = '<p style="margin: 15px 0px; padding: 0px; border: 0px; outline: 0px;">Hello</p>';
my $regex = qr/(<.+?)\s+style\s*=\s*(["']).*?\2(.*?>)/p;
my $subst = '\\1\\3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";