import Foundation
let pattern = #"(<.+?)\s+style\s*=\s*(["']).*?\2(.*?>)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"<p style="margin: 15px 0px; padding: 0px; border: 0px; outline: 0px;">Hello</p>"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1\3"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)