const regex = /(<.+?)\s+style\s*=\s*(["']).*?\2(.*?>)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(<.+?)\\s+style\\s*=\\s*(["\']).*?\\2(.*?>)', 'g')
const str = `<p style="margin: 15px 0px; padding: 0px; border: 0px; outline: 0px;">Hello</p>`;
const subst = `\1\3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);