using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<.+?)\s+style\s*=\s*([""']).*?\2(.*?>)";
string substitution = @"\1\3";
string input = @"<p style=""margin: 15px 0px; padding: 0px; border: 0px; outline: 0px;"">Hello</p>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}