import re
regex = re.compile(r"(<.+?)\s+style\s*=\s*([\"']).*?\2(.*?>)")
test_str = "<p style=\"margin: 15px 0px; padding: 0px; border: 0px; outline: 0px;\">Hello</p>"
subst = "\\1\\3"
result = regex.sub(subst, test_str)
if result:
print(result)