#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(<.+?)\s+style\s*=\s*(["']).*?\2(.*?>)"
Local $sString = "<p style="margin: 15px 0px; padding: 0px; border: 0px; outline: 0px;">Hello</p>"
Local $sSubst = "\1\3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)