re = /(<.+?)\s+style\s*=\s*(["']).*?\2(.*?>)/
str = '<p style="margin: 15px 0px; padding: 0px; border: 0px; outline: 0px;">Hello</p>'
subst = '\\1\\3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result