$re = '/(<.+?)\s+style\s*=\s*(["\']).*?\2(.*?>)/';
$str = '<p style="margin: 15px 0px; padding: 0px; border: 0px; outline: 0px;">Hello</p>';
$subst = "\1\3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;