# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(.*[_].*)*(.*)/Test My Ass Hour 123123123313213/g;t' <<< "test_my_ass_hour_123123123313213"