$re = '/(.*[_].*)*(.*)/';
$str = 'test_my_ass_hour_123123123313213';
$subst = "Test My Ass Hour 123123123313213";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;