package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(.*[_].*)*(.*)`)
var str = `test_my_ass_hour_123123123313213`
var substitution = "Test My Ass Hour 123123123313213"
fmt.Println(re.ReplaceAllString(str, substitution))
}