re = /(.*[_].*)*(.*)/
str = 'test_my_ass_hour_123123123313213'
subst = 'Test My Ass Hour 123123123313213'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result