import re
regex = re.compile(r"(.*[_].*)*(.*)")
test_str = "test_my_ass_hour_123123123313213"
subst = "Test My Ass Hour 123123123313213"
result = regex.sub(subst, test_str)
if result:
print(result)