use strict;
my $str = 'test_my_ass_hour_123123123313213';
my $regex = qr/(.*[_].*)*(.*)/p;
my $subst = 'Test My Ass Hour 123123123313213';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";