# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<body[^>]*>/$0<mynewtag>/g;t' <<< "<body class=\"wordpress y2015 m10 d23 h12 single s-y2010 s-m02\" style=\"width: 100%;\">
<body class=\"s-category-linux\" style=\"background-color: red;\">
<body class=\"wordpress y2015 m10 d23 h12 single s-y2010 s-m02 s-d10\" style=\"width: 100%;\"><div id=\"wrapper\"><div id=\"header\">"