const regex = /<body[^>]*>/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<body[^>]*>', 'g')
const str = `<body class="wordpress y2015 m10 d23 h12 single s-y2010 s-m02" style="width: 100%;">
<body class="s-category-linux" style="background-color: red;">
<body class="wordpress y2015 m10 d23 h12 single s-y2010 s-m02 s-d10" style="width: 100%;"><div id="wrapper"><div id="header">`;
const subst = `$0<mynewtag>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);