// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"<body[^>]*>").unwrap();
let string = "<body class=\"wordpress y2015 m10 d23 h12 single s-y2010 s-m02\" style=\"width: 100%;\">
<body class=\"s-category-linux\" style=\"background-color: red;\">
<body class=\"wordpress y2015 m10 d23 h12 single s-y2010 s-m02 s-d10\" style=\"width: 100%;\"><div id=\"wrapper\"><div id=\"header\">";
let substitution = "$0<mynewtag>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}