package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<body[^>]*>`)
var str = `<body class="wordpress y2015 m10 d23 h12 single s-y2010 s-m02" style="width: 100%;">
<body class="s-category-linux" style="background-color: red;">
<body class="wordpress y2015 m10 d23 h12 single s-y2010 s-m02 s-d10" style="width: 100%;"><div id="wrapper"><div id="header">`
var substitution = "$0<mynewtag>"
fmt.Println(re.ReplaceAllString(str, substitution))
}